SaveText.Ru

Без имени
  1. &НаСервере
  2. Процедура ЗагрузкаДанныхНаСервере(Путь)
  3.  // Вставить содержимое обработчика.
  4.  Эксель = Новый COMОбъект("Excel.Application");
  5.  книга = эксель.workbooks.open(путь);
  6.  лист = книга.worksheets(1);
  7.  стр = лист.cells(1,1).specialcells(11,11).row;
  8.  Для счетчик = 3 по стр цикл
  9.   спр = Справочники.Сотрудники.СоздатьЭлемент();
  10.   спр.Наименование = лист.cells(счетчик, 3).value;
  11.   спр.Фамилия_Имя_Отчество = лист.cells(счетчик, 3).value;
  12.   //спр.Должность = лист.cells(счетчик, 2).value;
  13.   //спр.Организация = лист.cells(счетчик, 1).value;
  14.   //спр.ФИО = лист.cells(счетчик, 4).value;
  15.   спр.дата_рождение = лист.cells(счетчик, 4).value;
  16.    
  17.   Проверка = Справочники.Сотрудники.НайтиПоНаименованию(Спр.Наименование, Истина);
  18.   Если Проверка.Пустая() Тогда
  19.    Спр.Записать();
  20.   Иначе
  21.    Сообщить ( "Этот сотрудник уже есть " + Спр.Наименование);
  22.    
  23.  
  24.   //спр.Записать();
  25.    
  26.    
  27.     Конецесли;
  28.  КонецЦикла;
  29.  эксель.Application.quit();
  30.  
  31. КонецПроцедуры
  32.  
  33. &НаКлиенте
  34. Процедура ЗагрузкаДанных(Команда)
  35.  Режим = РежимДиалогаВыбораФайла.Открытие;
  36.  Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
  37.  Если Диалог.Выбрать() тогда
  38.   Путь = Диалог.ПолноеИмяФайла;
  39.  КонецЕсли;
  40.   ЗагрузкаДанныхНаСервере(Путь);
  41. КонецПроцедуры

Share with your friends:

Print