SaveText.Ru

Без имени
  1.    ЗапретитьОткрытиеНесколькихСеансов = УправлениеПользователями.ПолучитьЗначениеПоУмолчанию(глЗначениеПеременной("глТекущийПользователь"), "ЗапретитьОткрытиеНесколькихСеансов");
  2.     Если ЗапретитьОткрытиеНесколькихСеансов Тогда
  3.         ТекущийНомерСоединения = НомерСоединенияИнформационнойБазы();
  4.         УникальныйИдентификаторПользователя = ПользователиИнформационнойБазы.ТекущийПользователь().УникальныйИдентификатор;
  5.        
  6.         МассивСоединений = ПолучитьСоединенияИнформационнойБазы();
  7.         Для Каждого ТекСоединение Из МассивСоединений Цикл
  8.             Если (ТекСоединение.ИмяПриложения = "1CV8")
  9.                И (НЕ ТекСоединение.НомерСоединения = ТекущийНомерСоединения)
  10.                И (НЕ ТекСоединение.Пользователь = неопределено)
  11.                И (ТекСоединение.Пользователь.УникальныйИдентификатор = УникальныйИдентификаторПользователя) Тогда
  12.              
  13.                 Предупреждение("Пользователем с таким именем уже выполнен вход в систему");
  14.                 ЗавершитьРаботуСистемы(Ложь);
  15.                 Возврат;
  16.                
  17.             КонецЕсли;
  18.         КонецЦикла;    
  19.     КонецЕсли;

Share with your friends:

Print