SaveText.Ru

Без имени
  1.         //slawa Нач 20200407 13:04 (ID:374GZ8)
  2.         Если Отказ <> Истина Тогда
  3.                 ВнНомера = ТекущийОбъект.КонтактнаяИнформация.НайтиСтроки(Новый Структура("Вид", Справочники.ВидыКонтактнойИнформации.ПолучитьСсылку(Новый УникальныйИдентификатор("8270dae9-3df7-11e7-80ca-c80aa91f9e91")))); // Внутренний телефон
  4.                 Если ТекущийОбъект.Недействителен Тогда
  5.                         Для каждого внНомер Из ВнНомера Цикл
  6.                                 внНомер.Представление = "";
  7.                                 внНомер.ЗначенияПолей = "";
  8.                                 внНомер.НомерТелефона = "";
  9.                                 внНомер.НомерТелефонаБезКодов = "";
  10.                         КонецЦикла;
  11.                 Иначе // проверка на уникальность внутреннего номера
  12.                         массВнНомера = Новый Массив;
  13.                         Для каждого внНомер Из ВнНомера Цикл
  14.                                 Если ЗначениеЗаполнено(СокрЛП(внНомер.НомерТелефона)) Тогда
  15.                                         массВнНомера.Добавить(СокрЛП(внНомер.НомерТелефона));
  16.                                 КонецЕсли;
  17.                         КонецЦикла;
  18.                        
  19.                         Если массВнНомера.Количество() > 0 Тогда
  20.                                 ЗапросПоВнНомерам = Новый Запрос;
  21.                                 ЗапросПоВнНомерам.Текст =
  22.                                 "ВЫБРАТЬ РАЗЛИЧНЫЕ
  23.                                 |       ПользователиКонтактнаяИнформация.Ссылка,
  24.                                 |       ПользователиКонтактнаяИнформация.Ссылка.Наименование как Пользователь,
  25.                                 |       ПользователиКонтактнаяИнформация.НомерТелефона
  26.                                 |ИЗ
  27.                                 |       Справочник.Пользователи.КонтактнаяИнформация КАК ПользователиКонтактнаяИнформация
  28.                                 |ГДЕ
  29.                                 |       ПользователиКонтактнаяИнформация.Ссылка <> &Ссылка
  30.                                 |       И ПользователиКонтактнаяИнформация.Вид = &Вид
  31.                                 |       И ПользователиКонтактнаяИнформация.НомерТелефона В(&массВнНомера)
  32.                                 |
  33.                                 |УПОРЯДОЧИТЬ ПО
  34.                                 |       ПользователиКонтактнаяИнформация.Ссылка.Наименование";
  35.                                 ЗапросПоВнНомерам.УстановитьПараметр("массВнНомера", массВнНомера);
  36.                                 ЗапросПоВнНомерам.УстановитьПараметр("Ссылка", ТекущийОбъект.Ссылка);
  37.                                 ЗапросПоВнНомерам.УстановитьПараметр("Вид", Справочники.ВидыКонтактнойИнформации.ПолучитьСсылку(Новый УникальныйИдентификатор("8270dae9-3df7-11e7-80ca-c80aa91f9e91"))); // Внутренний телефон
  38.                                 резЗапросПоВнНомерам = ЗапросПоВнНомерам.Выполнить();
  39.                                 Если не резЗапросПоВнНомерам.Пустой() Тогда
  40.                                         выбЗапросПоВнНомерам = резЗапросПоВнНомерам.Выбрать();
  41.                                         Пока выбЗапросПоВнНомерам.Следующий() Цикл
  42.                                                 Сообщить("У пользователя "+выбЗапросПоВнНомерам.Пользователь+" существует номер "+выбЗапросПоВнНомерам.НомерТелефона);
  43.                                                 Отказ = Истина;
  44.                                         КонецЦикла;
  45.                                 КонецЕсли;
  46.                                 Если Отказ = Истина Тогда
  47.                                         Сообщить("Запись не возможна! Не должно быть дубликатов номеров");
  48.                                 КонецЕсли;
  49.                         КонецЕсли;
  50.                          
  51.                 КонецЕсли;
  52.         КонецЕсли;
  53.         //slawa Кон 374GZ8
  54.  
  55.                 //slawa Нач 20200407 13:04 (ID:374GZ8)
  56.                 КонтактнаяИнформацияПоле8270dae9x3df7x11e7x80caxc80aa91f9e911 = "";    // Внутренний телефон
  57.                 //slawa Кон 374GZ8
  58.  
  59.  

Share with your friends:

Print