SaveText.Ru

Без имени
  1. Функция ПолучитьДатуИзСтроки(Стр)
  2.  
  3.          Д = Дата("00010101000000");
  4.  
  5.          ЕслиПустаяСтрока(Стр) Тогда
  6.              Возврат Д;
  7.          КонецЕсли;
  8.  
  9.          ЕслиНайти(Стр,".") > 0 Тогда
  10.  
  11.              Если Найти(Стр,":") > 0 И Найти(Стр," ") > 0 Тогда
  12.                  М = ОбщегоНазначения.РазложитьСтрокуВМассивПодстрок(Стр," ");
  13.                  ВозвратПолучитьДатуИзСтроки(М[0]);
  14.              КонецЕсли;
  15.  
  16.              М = ОбщегоНазначения.РазложитьСтрокуВМассивПодстрок(Стр,".");
  17.  
  18.          ИначеЕсли Найти(Стр,"/")>0 Тогда
  19.  
  20.              М = ОбщегоНазначения.РазложитьСтрокуВМассивПодстрок(Стр,"/");
  21.  
  22.          ИначеЕсли Найти(Стр,",")>0 Тогда
  23.  
  24.              М = ОбщегоНазначения.РазложитьСтрокуВМассивПодстрок(Стр,",");
  25.  
  26.          ИначеЕсли Найти(Стр,"-")>0 Тогда
  27.  
  28.              М = ОбщегоНазначения.РазложитьСтрокуВМассивПодстрок(Стр,"-");
  29.  
  30.          КонецЕсли;
  31.  
  32.          Попытка
  33.  
  34.              Если М.Количество() = 3 Тогда //"01.02.13" или "01.02.2013"
  35.                  Год = ?(СтрДлина(М[2]) = 2,2000 + М[2],М[2]);
  36.                  Д = Дата(Год,М[1],М[0]);
  37.              ИначеЕсли М.Количество() = 2 Тогда //"02.13" или "02.2013";
  38.                  Год = ?(СтрДлина(М[1]) = 2,2000 + М[1],М[1]);
  39.                  Д = Дата(Год,М[0],1);
  40.              КонецЕсли;
  41.  
  42.          Исключение
  43.          КонецПопытки;
  44.  
  45.          ВозвратД;
  46.  
  47.      КонецФункции

Share with your friends:

Print